백본만 시스코로 설정한다.
회사정책이 바뀔 경우도 재분배
acl확장인 루프백이 쓰임
@시드(Seed) 메트릭의 사용 / 기본메트릭
외부에서 끌고 들어온 메트릭을 결정해줘야 한다.
메트릭계산을 위한 씨앗
#R1
router eigrp 110
network 10.0.0.0
redistribute rip
default-metric 1544 2000 255 1 1500
대역폭 딜레이 신뢰도 부하 MTU
#기본 시드메트릭
RIP 무한대//외부에서 끌고 들어올 떄는 홉카운트를 정한다
EIGRP 무한대//대역폭 딜레이 신뢰도 부하 MTU설정
OSPF 20//E2type으로 기본설정 20.안 적어줘도 된다.
외부에서 끌고온 다른반 애를 위해 설정해줘야 됨
하나의 라우터에서만 재분배
다수의 라우터에서만 재분배
#RIP으로 재분배 설정하기
redistribute rip [process-id] metric metric-value]
각각 경계에 있는 곳에서만 재분배 한다.
rip은 변경되는게 없다.
#OSPF 재분배 명령어
redistribute protocol [process-id] [subnets] [metric-type type-value: E1타입으로 바꾸려면 metric-type 1로 하면된다]
router ospf 1
redistribute eigrp 100 subnets metric-type 1
# EIGRP 재분배 명령어
redistribute protocol [process-id] [metric metric-value]
기본 값들 default-metric 1544 2000 255 1 1500
밴드위드 1544, 열개묶음단위로 묶음 2000*10, 1~255, 1~255,serial네트워크는 MTU 1500byte가 한계
안적어줘도 된다. default-metric
rip ospf경계설정
router ospf 1
network 10.0.0.8 0.0.0.3 area 0
redistribute rip subnets metric 300 // 20 ->300
router rip
network 10.0.0.0
version 2
passive-interface s2
redistribute ospf 1 metric 5
ospf에서는 area단위로만 축약된다.
# REDI LAB1
R1
en
conf t
int s1/0
no shut
encap fram
no frame inverse
int s1/0.12 p
ip addr 31.31.12.1 255.255.255.0
frame interface-dlci 102
int l 0
ip addr 31.31.1.1 255.255.255.0
R2
en
conf t
int s1/0
no shut
encap fram
no frame inverse
int s1/0.12 p
ip addr 31.31.12.2 255.255.255.0
frame interface-dlci 201
int s1/0.23 p
ip addr 31.31.23.1 255.255.255.0
frame interface-dlci 203
int l 0
ip addr 31.31.2.2 255.255.255.0
ip route 31.31.1.0 255.255.255.0 31.31.1.1
R3
en
conf t
int s1/0
no shut
encap fram
no frame inverse
int s1/0.23 p
ip addr 31.31.23.2 255.255.255.0
frame interface-dlci 302
int l 0
ip addr 31.31.3.3 255.255.255.0
----------------
static과 rip v2설정
R1
conf t
ip route 0.0.0.0 0.0.0.0 31.31.12.2
R2
ip route 31.31.1.0 255.255.255.0 31.31.12.1
router rip
version 2
network 31.31.12.0
network 31.31.23.0
network 31.31.2.0
no auto
passive-interface serial 1/0.12
router rip
redistribute static
default-metric 3
redistribute static metric 2
R3
router rip
version 2
network 31.31.0.0
no auto
default-metric 2
\\\\\\\\\\\\\REDI2
R1
en
conf t
int s1/0
no shut
encap fram
no frame inverse
int s1/0.12 p
ip addr 31.31.12.1 255.255.255.0
frame interface-dlci 102
int l 0
ip addr 31.31.1.1 255.255.255.0
R2
en
conf t
int s1/0
no shut
encap fram
no frame inverse
int s1/0.12 p
ip addr 31.31.12.2 255.255.255.0
frame interface-dlci 201
int s1/0.23 p
ip addr 31.31.23.1 255.255.255.0
frame interface-dlci 203
int l 0
ip addr 31.31.2.2 255.255.255.0
ip route 31.31.1.0 255.255.255.0 31.31.1.1
R3
en
conf t
int s1/0
no shut
encap fram
no frame inverse
int s1/0.23 p
ip addr 31.31.23.2 255.255.255.0
frame interface-dlci 302
int l 0
ip addr 31.31.3.3 255.255.255.0
--------------
R1
conf t
router eigrp 1
network 31.31.12.0 0.0.0.255
network 31.31.1.0 0.0.0.255
no auto
R2
router eigrp 1
network 31.31.12.0 0.0.0.255
router rip
version 2
no auto
network 31.31.23.0
network 31.31.2.0
router eigrp 1
redistribute rip metric 1544 2000 255 1 1500//eigrp를 rip으로 보낼 때
router rip
redistribute eigrp 1 metric 2 //rip을 eigrp로 보낼 때
R3
router rip
version 2
no auto
network 31.31.23.0
network 31.31.3.0
1544kbps
\\\\\\\\\\\\\\\\
립을 올리고
ospf를 내려서 상호 통신
LAP3
@R1
conf t
router eigrp 1
network 31.31.12.0 0.0.0.255
network 31.31.1.0 0.0.0.255
no auto
@R2
router eigrp 1
network 31.31.12.0 0.0.0.255
no auto
router ospf 2
network 31.31.23.0 0.0.0.255 area 0
network 31.31.2.0 0.0.0.255 area 0
router ospf 2
redistribute eigrp 1 subnets //ospf가 eigrp정보를 받게 함
router eigrp 1
redistribute ospf 2 metric 1544 2000 255 1 1500
//eigrp가 ospf정보를 받게 함
@R3
router ospf 3
network 31.31.23.0 0.0.0.255 area 0
network 31.31.3.0 0.0.0.255 area 0
-----------------------------마지막 꽃
neighbor 22.22.15.2 priority 0
## R1
en
conf t
int lo 0
ip addr 31.31.1.1 255.255.255.0
int s1/0
encap frame
no frame inverse-arp
ip addr 22.22.15.1 255.255.255.0
frame-relay map ip 22.22.15.2 105
ip ospf hello-interval 10
no shut
exi
router ospf 1
network 22.22.15.0 0.0.0.255 area 0
network 31.31.1.0 0.0.0.255 area 0
##R2 //스태틱으로 설정
en
conf t
int lo 0
ip addr 31.31.2.2 255.255.255.0
int s1/0
encap frame
no frame inverse-arp
no shut
ip addr 22.22.25.1 255.255.255.0
frame-relay map ip 22.22.25.2 205
no shut
exit
ip route 0.0.0.0 0.0.0.0 22.22.25.2
## R3 //eigrp로 설정하라.
en
conf t
int lo 0
ip addr 31.31.3.3 255.255.255.0
int s1/0
encap frame
no frame inverse-arp
ip addr 22.22.35.1 255.255.255.0
frame-relay map ip 22.22.35.2 305 broadcast
ip hello-interval eigrp 1 10
ip hold-time eigrp 1 30
no shut
exi
router eigrp 1
no auto
network 22.22.35.0 0.0.0.255
network 31.31.3.0 0.0.0.255
## R4
en
conf t
int lo 0
ip addr 31.31.4.4 255.255.255.0
int s1/0
encap frame
no frame inverse-arp
ip addr 21.21.45.1 255.255.255.0
frame-relay map ip 21.21.45.2 405
no shut
exi
router rip
version 2
no auto
network 21.21.45.0
network 31.31.2.2
## R5
en
conf t
int s1/0
no shut
encap frame
no frame inverse-arp
int s1/0.1 p
ip addr 22.22.15.2 255.255.255.0
frame-relay interface-dlci 501
ip ospf hello-interval 10
ip ospf network non-broadcast
int s1/0.2 p
ip addr 22.22.25.2 255.255.255.0
frame-relay interface-dlci 502
int s1/0.3 p
ip addr 22.22.35.2 255.255.255.0
frame-relay interface-dlci 503
ip hello-interval eigrp 1 10
ip hold-time eigrp 1 30
int s1/0.4 p
ip addr 21.21.45.2 255.255.255.0
frame-relay interface-dlci 504
exi
router ospf 5
network 22.22.15.0 0.0.0.255 area 0
neighbor 22.22.15.1 priority 1
//해보고 없을 시에 이리로 보냄 디폴트임.(ospf끝)R1
exi
ip route 31.31.2.0 255.255.255.0 22.22.25.1
//스태틱으로 전송 R2
router eigrp 1
network 22.22.35.0 0.0.0.255
no auto
exi
//eigrp설정
router rip
version 2
no auto
network 21.21.45.0
렙4번 전체통신
렙5번 다 하면 문제 생긴다 발견해오라.
\\\\\\\\\\REDI LAB5
R1
en
conf t
int l 0
ip addr 3.3.1.1 255.255.255.0
int s1/0
ip addr 3.3.12.1
no shut
exi
router ospf 1
network 3.3.12.0 0.0.0.255 area 0
network 3.3.1.0 0.0.0.255 area 0
R2
en
conf t
int l 0
ip addr 3.3.2.2 255.255.255.0
int s1/0
ip addr 3.3.12.2 255.255.255.0
no shut
int f0/0
ip addr 3.3.23.2 255.255.255.0
no shut
exi
router ospf 2
network 3.3.12.0 0.0.0.255 area 0
network 3.3.2.0 0.0.0.255 area 0
exi
router eigrp 2
network 3.3.23.0 0.0.0.255
no auto
R3
en
conf t
int l 0
ip addr 3.3.3.3 255.255.255.0
int f0/0
ip addr 3.3.23.3 255.255.255.0
no shut
int s1/0
encap frame
no frame inverse-arp
no shut
ip addr 3.3.34.3 255.255.255.0
frame map ip 3.3.34.4 304
router eigrp 2
network 3.3.23.0 0.0.0.255
network 3.3.3.0 0.0.0.255
no auto
router rip
network 3.3.34.0
no auto
exi
R4
en
conf t
int l 0
ip addr 3.3.4.4 255.255.255.0
int s1/0
no shut
encap frame
no frame inverse-arp
ip addr 3.3.34.4 255.255.255.0
frame map ip 3.3.34.3 403
router rip
network 3.3.34.0
network 3.3.4.0
no auto
'CCNP(ROUTER)' 카테고리의 다른 글
20일차 static, EIGRP,RIP,OSPF를 이용한 꽃과 AD에 따른 루프방지법 (0) | 2013.06.03 |
---|---|
18일차. ABR,ASBR 경로축약 및 OSPF 인증 (0) | 2013.06.03 |
17일차 라우터의 STUB과 NSSA (0) | 2013.06.03 |
16일차. OSPF의 네트워크타입에 따른 BR,BDR (0) | 2013.06.03 |
15일차 OSPF의 통신 (0) | 2013.05.27 |