##서머리
rip,eigrp
ip summary-address ei
어느지점에서든 명령어를 사용가능하나,
광고하려는(나가는 부분에)쓴다.
ospf 경계
ABR,ASBR만 가능
ABR: 다른 area내용을 축약해서 받아옴
ASBR: 외부라우팅을 축약해서 받는다.
ABR: 3번축약
ASBR:5번축약
트래픽줄고, 메모리 줄고, cpu감소
루프방지용으로 null 0를 만들어서 자세한 정보가없으면 null 0로 보낸다.
\\\\\\\\\\\\\\
#ABR 축약
area area-id range address mask [advertise | not-advertise] [cost cost]
area 몇번 축약 range 축약된IP MASK
#ASBR
외부랑 연결된 ASBR에 적음
Router(config-router)#summary-address address mask [not-advertise] [tag tag]
축약된 동네이름, 서브넷마스
크
상호축약이 가능하다, 상호축약시 상대방은 축약된 정보를
R1(config-router)# area 0 range 172.16.96.0 255.255.224.0
R1(config-router)# area 1 range 172.16.32.0 255.255.224.0
ASBR(config-router)#summary-address 172.16.32.0 255.255.224.0
#디폴트 라우터
s*
o*(default는 *이다)
상세정보가 없을 때 디폴트로 간다. 그래서 폐기되는 영역이 없다.
default-information originate //*S스태틱 디폴트가 있을 때
default-information originate always//없어도 되게 하려고함. 내부에 광고해줌
R1#
router ospf 100
network 10.1.1.1 0.0.0.0 area 0
default-information originate metric 10
ip route 0.0.0.0 0.0.0.0 198.1.1.1
R2#
router ospf 100
network 10.2.1.1 0.0.0.0 area 0
default-information originate metric 100
ip route 0.0.0.0 0.0.0.0 198.2.1.1
//1을 사용
라우트를 줄여서 디폴트로하면 줄어든다.
Stub:3을 축약해받음 외부경로는 모두 E2로나타난다.
O,O IA, O E2 -> O, O IA, O*
totally stubby : 3,5를 모두 축약해 받음
O,O IA, O E2 -> O, O*
NSSA(Not-so-stubby area) : type7번을
N2,N1,O IA -> O IA,O*
totally NSSA -> O, O*
127
stub : 123(o, o IA, o*)
totally stub: (o,o*)
NSSA : O, O IA, O*
totally nssa: O,O*
#Stub Area Configuration
걸쳐진 모든라우터에 다 적어줘야된다.
#NSSA Configuration
R3(config-router)#area 2 nssa
area 2 nssa
area 2 nssa default-information-originate
area 2 default-cost 10
\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
경계 마지막부분
1.stub
area 1 stub area ? stub
2. Totally stub
area ? stub no-summary area ? stub
abr에만 no-summary붙여준다.
3.nssa
area 1 nssa default area ? nssa
4.totally NSSA
area 1 nssa no-su area ? nssa
\\\\\\\\\\\\\\\\\\\\\
rap7
## R1
en
conf t
int lo 0
ip addr 21.21.1.1 255.255.255.0
int lo 1
ip addr 1.1.1.1 255.255.255.0
int s1/0
no shut
encap frame
no frame inverse-arp
ip ospf hello-interval 10
ip ospf dead-interval 40
int s1/0.12 p
ip addr 21.21.12.1 255.255.255.0
frame-relay interface-dlci 102
ip ospf hello-interval 10
ip ospf dead-interval 40
exi
router ospf 1
network 21.21.1.0 0.0.0.255 area 1
network 21.21.12.0 0.0.0.255 area 1
## R2
en
conf t
int lo 0
ip addr 21.21.2.2 255.255.255.0
int s1/0
no shut
encap frame
no frame inverse-arp
int s1/0.12 m
ip addr 21.21.12.2 255.255.255.0
frame-relay map ip 21.21.12.1 201 broadcast
ip ospf hello-interval 10
ip ospf dead-interval 40
ip ospf network point-to-point
int s1/0.23 m
ip addr 21.21.23.1 255.255.255.0
frame-relay map ip 21.21.23.2 203 broadcast
ip ospf hello-interval 10
ip ospf dead-interval 40
ip ospf network point-to-point
exi
router ospf 2
network 21.21.2.0 0.0.0.255 area 0
network 21.21.12.0 0.0.0.255 area 1
network 21.21.23.0 0.0.0.255 area 0
## R3
en
conf t
int lo 0
ip addr 21.21.3.3 255.255.255.0
ip addr 21.21.4.3 255.255.255.0 se
ip addr 21.21.5.3 255.255.255.0 se
ip addr 21.21.6.3 255.255.255.0 se
ip addr 21.21.7.3 255.255.255.0 se
int lo 3
ip addr 3.3.3.3 255.255.255.0
ip addr 3.3.4.3 255.255.255.0 se
ip addr 3.3.5.3 255.255.255.0 se
ip addr 3.3.6.3 255.255.255.0 se
ip addr 3.3.7.3 255.255.255.0 se
int s1/0
no shut
encap frame
no frame inverse-arp
int s1/0.23 p
ip addr 21.21.23.2 255.255.255.0
frame interface-dlci 302
ip ospf hello-interval 10
ip ospf dead-interval 40
router ospf 3
network 21.21.23.0 0.0.0.255 area 0
network 21.21.2.0 0.0.0.255 area 0
network 21.21.0.0 0.0.7.255 area 0
---------3번
R3
router ospf 3
redistribute connected subnets
---------4번
R2
rouet ospf 2
area 0 range 21.21.3.0 255.255.248.0
---------5번
R2
router ospf 2
summary-address 3.3.0.0 255.255.248.0
----------6번
R1,R2
router) area 1 stub
----------7번
R1
area 1 stub
R2
area 1 stub no-summary
area 1 default-cost 5
----------8번
R1(config-router)#redistribute connected subnets
Warning: Router is currently an ASBR while having only one area which is a stub area
---------9번
R1(config-router)#area 1 nssa
R2(config-router)#area 1 nssa default-information-originate
--------10번
R1(config-router)#area 1 nssa
R2(config-router)#area 1 nssa no-summary
\\\\\\\\\\\인증
@심플
패스워드 있으니까 교환해보자
네이버간에 케이블로 연결된 인터페이스에서 한다.
R1,R2(config-if)#ip ospf authentication-key [key]양쪽 똑같이 정한다.
R1(config-if)# ip ospf authentication//전체는 이거만 적는다.
R1(config-router)# area area-number authentication
//ospf에서는 area별로 설정할 수도 있다.
## 가상링크 인증
area [경유하는 area] virtual-link [상대방]//까지는 가상링크
area 1 virtual-link 3.3.3.3 authentication-key cisco
@ md5
키생성
(if)ip ospf message-digest-key [key-번호] md5 [비번]
적용
(if)ip ospf authentication message-digest//적용
라우터모드
R1(config-router)# area [area-number] authentication [message-digest:MD5]
eigrp는 낮은 키번호 전달해서 비교한다.
#트러블슈팅
인접관계 맺을 떄 제대로 된지 확인
R1# debug ip ospf adj
\\\\\\\\\\\
LAB8
R1
en
conf t
int s1/1
ip addr 20.1.14.1 255.255.255.0
no shut
int s1/0
no shut
encap frame
no frame inverse-arp
ip addr 20.1.123.1 255.255.255.0
frame map ip 20.1.123.2 102 broadcast
frame map ip 20.1.123.3 103 broadcast
ip ospf hello-interval 10
ip ospf dead-interval 40
exi
int loop 0
ip addr 30.30.1.1 255.255.255.0
R2
en
conf t
int s1/0
no shut
encap frame
no frame inverse-arp
int s1/0.123 p
ip addr 20.1.123.2 255.255.255.0
frame interface-dlci 201
ip ospf hello-interval 10
ip ospf dead-interval 40
int lo 2
ip addr 2.2.0.1 255.255.255.0
ip addr 2.2.1.1 255.255.255.0 se
ip addr 2.2.2.1 255.255.255.0 se
ip addr 2.2.3.1 255.255.255.0 se
int lo 0
ip addr 30.30.2.2 255.255.255.0
R3
en
conf t
int s1/0
no shut
encap frame
no frame inverse-arp
int s1/0.123 m
ip addr 20.1.123.3 255.255.255.0
frame map ip 20.1.123.1 301 broad
ip ospf network point-to-multi
ip ospf hello-interval 10
ip ospf dead-interval 40
int lo 3
ip addr 3.3.0.1 255.255.255.0
ip addr 3.3.1.1 255.255.255.0 se
ip addr 3.3.2.1 255.255.255.0 se
ip addr 3.3.3.1 255.255.255.0 se
int lo 0
ip addr 30.30.3.3 255.255.255.0
\\\\\\\\\\\\\\\
R1
router ospf 1
network 30.30.1.1 0.0.0.0 area 1
network 20.1.123.1 0.0.0.0 area 0
network 20.1.14.1 0.0.0.0 area 1
R2
router ospf 2
network 20.1.123.2 0.0.0.0 area 0
network 30.30.2.2 0.0.0.0 area 0
R3
router ospf 3
network 20.1.123.3 0.0.0.0 area 0
network 30.30.3.3 0.0.0.0 area 0
network 3.3.0.0 0.0.3.255 area 0
\\\\\\\\\\
---------------1
ip ospf network non-broadcast
---------------2
R2,3
(config-if)ip ospf priority 0
\\\\\\\\\\\\\\\
R1
router)
neigbor 20.1.123.2 priority 0
neigbor 20.1.123.3 priority 0
R2
neigbor 20.1.123.1 priority 1
R3
neigbor 20.1.123.1 priority 1
http://blog.naver.com/kindboy84?Redirect=Log&logNo=70096051255
'CCNP(ROUTER)' 카테고리의 다른 글
20일차 static, EIGRP,RIP,OSPF를 이용한 꽃과 AD에 따른 루프방지법 (0) | 2013.06.03 |
---|---|
19일차 RIP,OSPF,EIGRP 재분배 (0) | 2013.06.03 |
17일차 라우터의 STUB과 NSSA (0) | 2013.06.03 |
16일차. OSPF의 네트워크타입에 따른 BR,BDR (0) | 2013.06.03 |
15일차 OSPF의 통신 (0) | 2013.05.27 |